Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Customer Portal - Account Management degradation

Incident Report for Infobip

Resolved

This degradation has been resolved.

Start (UTC): 25 February 2025 14:50
End (UTC): 25 February 2025 15:03
Impact: You may have experienced issues using our Account Management page.
Posted Feb 25, 2025 - 15:18 UTC

Investigating

This is to inform you that we are currently experiencing degradation of our Customer Portal service with Account Management. You might experience issues while trying to use the portal or its services. We are currently investigating this issue, and we'll share more information as soon as possible.
Posted Feb 25, 2025 - 15:03 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe)).