Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 11:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 08:00 UTC
Scheduled
We will be conducting an emergency database maintenance at our Malaysia data center within the specified time-frame. During this process, you may experience brief disruptions in operation of services corresponding to the components listed below. This maintenance is essential to keep our databases and services up-to-date and ensure they operate at peak performance.
Start (UTC): 30 September 2025 08:00 End (UTC): 30 September 2025 11:00 Purpose: Database maintenance
Posted Sep 24, 2025 - 08:14 UTC
This scheduled maintenance affected: Number Lookup (Malaysia), WhatsApp Business (Malaysia), SMPP (Malaysia), SMS (Malaysia), HTTP API (Malaysia), SIP Trunk (Malaysia), and Voice (Malaysia).