After investigation, it was determined that the issue originated on our partner TCR's platform. We have now received confirmation from TCR that the issue has been fully resolved, and their service is once again operational.
Start (UTC): 21 August 11:00 End (UTC): 21 August 17:25
Impact: You may have experienced issues and receive error 503 when attempting to create new 10DLC campaigns or update existing ones.
Posted Aug 21, 2025 - 18:59 UTC
Identified
We are currently investigating an issue causing 10DLC campaign provisioning delays. We are checking with our partners for resolution.
Posted Aug 21, 2025 - 18:02 UTC
This incident affected: Channels and Numbers (United States).