Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Saudi Arabia - Moments and Push Notification Delays

Incident Report for Infobip

Resolved

The issue has been successfully resolved, and the affected service is now fully operational.

During this period, our Push Notification service in the Saudi Arabia Data Center experienced increased processing latency, which may have delayed push notifications for Moments Flow campaigns. All messages were delivered during the incident.

Start (UTC): 27 August 15:29
End (UTC): 27 August 16:32

Impact: Delayed delivery of push notifications on the Saudi Arabia Data Center
Posted Aug 27, 2026 - 17:01 UTC

Identified

The source of the processing delays at our Saudi Arabia Data Center has been identified. Processing latency is in the process of recovering.
Posted Aug 27, 2026 - 16:31 UTC

Investigating

We are currently observing message processing delays affecting Moments and Push Notifications on our Saudi Arabia (SA3) Data Center. The issue is being investigated and more information will follow in the next update.
Posted Aug 27, 2026 - 16:10 UTC
This incident affected: Mobile Push Notifications (Saudi Arabia) and Moments (Saudi Arabia).