Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - 2FA service degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the service is once again operational. We experience issues with 2FA service affecting 2FA codes generation and delivery.

Start (UTC): 12 March 12:19
End (UTC): 12 March 12:37
Impact: 2FA codes for logging in to Customer Portal might not have been generated or sent to the users
Posted Mar 12, 2026 - 13:02 UTC

Investigating

We are currently experiencing issues with 2FA service over Global (Europe) data center. The issue is currently being investigated and more information will follow in the next update.
Posted Mar 12, 2026 - 12:43 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe)).