The issue has been successfully resolved, and the services are once again operational. The investigation revealed that the incident ultimately only affected our Customer Portal and email delivery.
Start (UTC): 07 October 07:06 End (UTC): 07 October 07:58 Impact: Customer Portal slowness and email delivery delays
Posted Oct 07, 2025 - 08:12 UTC
Identified
The issue has been identified, and our team is currently working on a fix. Investigation showed that this incident is also affecting general services hosted on our Saudi Arabia data centre.
Posted Oct 07, 2025 - 07:51 UTC
Investigating
We are currently experiencing issues in our Saudi Arabia data centre. You may experience slowness and issues while using the Customer Portal and related services. Our dedicated team is currently investigating, and we'll share more information in the next update.
Posted Oct 07, 2025 - 07:27 UTC
This incident affected: Mobile Push Notifications (Saudi Arabia), Customer Portal Signup/Login (Saudi Arabia), People (Saudi Arabia), Moments (Saudi Arabia), Analyze (Saudi Arabia), Conversations (Saudi Arabia), Answers (Saudi Arabia), Channels and Numbers (Saudi Arabia), RCS (Saudi Arabia), Live Chat (Saudi Arabia), Email (Saudi Arabia), ChatApps (Saudi Arabia), SMS (Saudi Arabia), Number Lookup (Saudi Arabia), WhatsApp Business (Saudi Arabia), SMPP (Saudi Arabia), HTTP API (Saudi Arabia), SIP Trunk (Saudi Arabia), and Voice (Saudi Arabia).