Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - Subaccounts not displaying in the Portal

Incident Report for Infobip

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 18:07 UTC

Investigating

The Subaccounts are not displaying in the account settings on the Portal. Our internal team is actively investigating the extent of this issue, and further details will be provided shortly.
Posted Jul 03, 2025 - 17:53 UTC
This incident affected: Customer Portal Login/Homepage (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States).