We want to inform you that the previously reported degradation affecting the WhatsApp template management service has been resolved.
During the timeframe listed below, users may have experienced difficulties with creating, updating, and fetching WhatsApp templates via the HTTP API and Customer Portal, across multiple locations.
Start time (UTC): 22 May 2026 09:17 End time (UTC): 22 May 2026 11:59
Impact: WhatsApp template creation, update, and retrieval via HTTP API and Customer Portal.
Posted May 22, 2026 - 12:47 UTC
Update
Our dedicated team is still working to resolve the issue.
Posted May 22, 2026 - 11:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 22, 2026 - 10:43 UTC
Investigating
We are currently experiencing issues with our WhatsApp template management service. You may experience issues with updating, fetching, or creating WhatsApp templates over the HTTP API and customer portal. Our dedicated team is currently working on this and more updates will follow.
Posted May 22, 2026 - 10:06 UTC
This incident affected: WhatsApp Business (Brazil, EU Region-locked, Great Britain, Hong Kong, India, Indonesia, Malaysia, Pakistan, Qatar, Saudi Arabia, Singapore, Turkey, United Arab Emirates, United States).