Resolved
The incident has been resolved.
Start (UTC): 07 April 15:00
End (UTC): 07 April 16:20
Impact: During the specified timeframe, you may have experienced delays in traffic processing. Traffic was accepted but routed with delay.
Posted Apr 07, 2026 - 17:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 16:23 UTC
Update
We are continuing to investigate this issue.
Posted Apr 07, 2026 - 15:52 UTC
Investigating
We are currently experiencing an issue with all services on our Global (Europe) data center.
You may notice delays in processing traffic.
Our team is investigation and we will share more details in the following updates.
Posted Apr 07, 2026 - 15:51 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe)), People (Global (Europe)), Moments (Global (Europe)), Analyze (Global (Europe)), Conversations (Global (Europe)), Answers (Global (Europe)), Channels and Numbers (Global (Europe)), Other Portal Apps (Global (Europe)), Mobile Push Notifications (Global (Europe)), USSD (Global (Europe)), Integrations (Global (Europe)), RCS (Global (Europe)), MMS (Global (Europe)), Live Chat (Global (Europe)), Mobile Identity (Global (Europe)), Number Lookup (Global (Europe)), Email (Global (Europe)), WhatsApp Business (Global (Europe)), ChatApps (Global (Europe)), SMPP (Global (Europe)), HTTP API (Global (Europe)), SMTP (Global (Europe)), SMS (Global (Europe)), Voice (Global (Europe)), and SIP Trunk (Global (Europe)).