The degradation has been successfully resolved and the service is once again fully operational. During the incident time-frame you may have noticed an increase of "TEMP_REJECTION" error responses to your email validation service submissions.
Start (UTC): 30 October 16:54 (UTC) End (UTC): 31 October 12:15 (UTC)
Impact: increase of "TEMP_REJECTION" error responses for email validation service submissions
Posted Oct 31, 2025 - 12:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 12:26 UTC
Identified
The issue has been identified and our dedicated team is working on the resolution.
More information will follow in next update.
Posted Oct 31, 2025 - 10:05 UTC
Investigating
We are currently experiencing issue with our email validation service. Your requests may receive "TEMP_REJECTION" error response. The issue is currently being investigated and more information will follow in the next update.
Posted Oct 31, 2025 - 09:39 UTC
This incident affected: Email (Global (Europe), Indonesia).