This is to inform you that the scheduled maintenance of our Integrations and People services has been cancelled.
We apologize for the inconvenience. You will be informed in a timely manner if the maintenance is rescheduled.
Posted Oct 31, 2025 - 14:56 UTC
Scheduled
We will be performing emergency maintenance on our Integrations and People services across multiple locations to enhance the performance and reliability of our platform. During the maintenance window, you may experience irregular synchronization between your Integrations and People sections on the Customer Portal.
Start: 05 November 2025, 08:00 UTC End: 05 November 2025, 16:00 UTC Purpose: Integrations and People services upgrades and optimization
Posted Oct 27, 2025 - 12:05 UTC
This scheduled maintenance affected: People (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States) and Integrations (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States).