Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Moments service degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the degradation of Moments services and Flow module has been resolved. During the incident timeframe you may have experienced intermittent processing delays

Start (UTC): 19 September 12:45
End (UTC): 22 September 15:20

Impact: You may have experienced intermittent processing delays in the active Flows.
Posted Sep 23, 2025 - 10:22 UTC

Investigating

We are currently experiencing issues with our Moments services and Flow module hosted in our Global (Europe) location. Infobip customers utilizing Flow may experience intermittent processing delays. Our designated engineering team is investigating the issue further.
Posted Sep 23, 2025 - 09:24 UTC
This incident affected: Moments (Global (Europe)).