Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Numbers services degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved, and services related to Numbers and Channels are once again operational.

Start time (UTC): 15 May 2025 14:41
End time (UTC): 15 May 2025 15:57
Impact: You may have experienced issues while trying to utilize services related to our Numbers and Channels module (such as Broadcasts, WhatsApp Sender displaying, etc) or invoking API calls to Numbers endpoints (/Numbers/1/Numbers).
Posted May 15, 2025 - 16:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 16:14 UTC

Update

We are having a degradation of our Numbers Service in our Global(Europe) datacenter. You may experience issues using our numbers API and getting the senders' information over Portal. Our dedicated team is working to resolve the issue, and more updates will follow soon.
Posted May 15, 2025 - 16:04 UTC

Investigating

We are having a degradation of our Numbers Service in our Global(Europe) datacenter. You may experience issues using our numbers API and getting the senders' information over Portal. Our dedicated team is working to resolve the issue, and more updates will follow soon.
Posted May 15, 2025 - 16:03 UTC
This incident affected: Customer Portal Login/Homepage (Global (Europe)) and Channels and Numbers (Global (Europe)).