The maintenance activity has been successfully completed prior to the scheduled end-time, all services are fully functional.
Posted Jun 11, 2025 - 09:16 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2025 - 04:00 UTC
Update
We have updated the start time for this maintenance. The new maintenance window is: Start (UTC): 11 June 2025, 04:00 End (UTC): 11 June 2025, 11:00
Posted May 28, 2025 - 08:18 UTC
Scheduled
We will undergo a planned maintenance that includes an upgrade and optimization of our United States Data Center's networking equipment in the below specified time window with the goal of ensuring that our platform's infrastructure is performing optimally. Start (UTC): 11 June 2025 06:00 End (UTC): 11 June 2025 11:00 Purpose: Infrastructure upgrades
Connectivity interruptions of up to a cumulative of 15 minutes are possible toward services hosted on our United States Data Center during the activity interval.
Posted May 27, 2025 - 11:03 UTC
This scheduled maintenance affected: MMS (United States), SMTP (United States), Mobile Push Notifications (United States), Customer Portal Login/Homepage (United States), People (United States), Moments (United States), Analyze (United States), Conversations (United States), Answers (United States), Channels and Numbers (United States), Other Portal Apps (United States), Email (United States), RCS (United States), Live Chat (United States), ChatApps (United States), WhatsApp Business (United States), SMS (United States), Number Lookup (United States), SMPP (United States), HTTP API (United States), SIP Trunk (United States), and Voice (United States).