Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - Email Domain Creation Unavailable

Incident Report for Infobip

Resolved

This incident has been resolved.

Start (UTC): 16 July 2026 14:19
End (UTC): 16 July 2026 15:01

Impact: During this incident, you might have encountered difficulties creating new email domains within the specified timeframe.
Existing email traffic and previously configured domains were not affected at any point.
Posted Jul 16, 2026 - 15:19 UTC

Update

We are continuing to investigate this issue.
Posted Jul 16, 2026 - 14:53 UTC

Investigating

We are currently investigating an issue affecting the ability to create new email domains across all data centers.
Existing email traffic and previously configured domains are not impacted.

We are working on a resolution and will provide updates as the situation develops.
Posted Jul 16, 2026 - 14:51 UTC
This incident affected: Email (Brazil, Global (Europe), India, Indonesia, Pakistan, Qatar, Saudi Arabia, Singapore, United Arab Emirates, United States).