Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - WhatsApp Sending Delay

Incident Report for Infobip

Resolved

The Issue has been Successfully resolved, and noted services are operational once more.
During the time noted, experienced delays and expiry of traffic may have been noted.

Start: 26 February 2026 - (UTC) 16:01
End: 26 February 2026 - (UTC) 18:45
Impact: WhatsApp messaging Showed improved delay on forwarding of messages.
Posted Feb 26, 2026 - 19:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 18:54 UTC

Identified

We have Identified issues with sending of WhatsApp Messages with noticeable delay and are already implementing further corrections.
Posted Feb 26, 2026 - 18:03 UTC
This incident affected: WhatsApp Business (Global (Europe)).