Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - WhatsApp Inbound service degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the service is once again operational. The inbound messages were stacking in a queue due to message processing issue.

Start (UTC): 01 April 10:45
End (UTC): 01 April 12:21
Impact: The inbound messages might have been delivered with a delay
Posted Apr 01, 2025 - 12:29 UTC

Investigating

We are currently experiencing issues with WhatsApp Inbound service over Global (Europe) data center. The issue is currently being investigated and more information will follow in the next update.
Posted Apr 01, 2025 - 11:59 UTC
This incident affected: WhatsApp Business (Global (Europe)).