Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Multiple service degradation

Incident Report for Infobip

Resolved

The incident has been resolved. During the incident timeframe, you may have experienced delays in the delivery of inbound traffic as well as delays in delivery reports across multiple services hosted on our Global (Europe) data centers.

Start (UTC): 13 April 2026 09:24
End (UTC): 13 April 2026 11:39
Impact: Delays in inbound traffic delivery and delays in processing delivery reports.
Posted Apr 13, 2026 - 11:47 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 11:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 13, 2026 - 11:37 UTC

Investigating

We are currently experiencing degradation of multiple services hosted on the Global (Europe) data centers. You may experience processing issues and delivery delays for inbound traffic across multiple channels. Our designated teams are actively investigating the issue, and we will share updates accordingly.
Posted Apr 13, 2026 - 11:05 UTC
This incident affected: RCS (Global (Europe)), MMS (Global (Europe)), WhatsApp Business (Global (Europe)), ChatApps (Global (Europe)), and SMS (Global (Europe)).