Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 19:00 UTC
Scheduled
We will be conducting an emergency database maintenance at our India data center within the specified time-frame. During this process, you may experience brief disruptions in operation of services corresponding to the components listed below. This maintenance is essential to keep our databases and services up-to-date and ensure they operate at peak performance.
Start (UTC): 10 June 2025 19:00 End (UTC): 10 June 2025 21:00 Purpose: Database maintenance
Posted May 30, 2025 - 10:30 UTC
This scheduled maintenance affected: People (India), Analyze (India), Email (India), WhatsApp Business (India), and Voice (India).