This is to let you know that the scheduled maintenance has been postponed until further notice. The maintenance activity will be announced in a new post once scheduled.
Posted Jan 13, 2026 - 20:48 UTC
Completed
This is to let you know that the scheduled maintenance has been postponed until further notice. The maintenance activity will be announced in a new post once scheduled.
Posted Jan 13, 2026 - 20:46 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 13, 2026 - 20:00 UTC
Update
The planned maintenance has been rescheduled to another date.
Start (UTC): 13 January 2026 20:00 End (UTC): 13 January 2026 23:00
Posted Dec 10, 2025 - 08:47 UTC
Scheduled
We will be performing planned maintenance of network infrastructure at our Global (Europe) data center to upgrade core networking equipment, ensuring stability and optimal performance.
Preventive measures have been implemented to minimize any potential impact, however, brief connectivity interruptions may occur for services hosted at the Global (Europe) data center. Any disruptions are expected to last no longer than a total of 15 minutes within the scheduled maintenance window.
Start (UTC): 18 December 2025 20:00 End (UTC): 18 December 2025 23:00 Purpose: Network infrastructure upgrade and optimization
Posted Dec 03, 2025 - 11:40 UTC
This scheduled maintenance affected: Number Lookup (Global (Europe)), Email (Global (Europe)), WhatsApp Business (Global (Europe)), SMPP (Global (Europe)), HTTP API (Global (Europe)), SMS (Global (Europe)), Voice (Global (Europe)), and SIP Trunk (Global (Europe)).