Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Saudi Arabia - Customer Portal Degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the previously affected services are once again operational.
During the below timeframe, you may have experienced issues logging in to the Customer Portal or degraded performance of Customer Portal web pages and corresponding services.

Start (UTC): 02 May 09:58
End (UTC): 02 May 12:22
Impact: Degraded performance of Customer Portal
Posted May 02, 2025 - 12:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will keep you posted with further information.
Posted May 02, 2025 - 12:25 UTC

Update

We are continuing to investigate this issue.
Posted May 02, 2025 - 11:32 UTC

Update

We are continuing to investigate the issue.
Posted May 02, 2025 - 11:01 UTC

Investigating

We are currently experiencing issues with Customer Portal for the Saudi Arabia data center.
You may experience login issues and degraded performance of services on the customer portal.
The issue is currently being investigated and more information will follow in the next update.
Posted May 02, 2025 - 10:28 UTC
This incident affected: Customer Portal Login/Homepage (Saudi Arabia).