Start time (UTC): 08-05-2024 02:59 End time (UTC): 08-05-2024 05:11
Impact: Intermittent issues with receiving email delivery reports.
Posted May 08, 2024 - 05:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 08, 2024 - 05:12 UTC
Update
We are continuing to investigate this issue.
Posted May 08, 2024 - 04:29 UTC
Investigating
We are currently experiencing a problem with Email service processed over our India data center. You may experience intermittent issues, and there is a possibility that some email messages might not be delivered and in pending status. Our dedicated team is working on the issue and more information will follow in the next update.