Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Saudi Arabia - Moments service degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the service is once again operational. You might had experienced delayed processing of message traffic and issue with API call execution from Flows.

Start (UTC): 22 April 2026 11:25
End (UTC): 22 April 2026 11:47
Impact: Delayed processing of message traffic and issue with API call execution from Flows
Posted Apr 22, 2026 - 12:31 UTC

Investigating

We are currently experiencing issues with Moments service over Saudi Arabia data center. The issue is currently being investigated and more information will follow in the next update.
Posted Apr 22, 2026 - 12:07 UTC
This incident affected: Moments (Saudi Arabia).