Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations – Service Degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved, and the service is once again operational.

Start (UTC): 12 May 2026 17:09
End (UTC): 12 May 2026 19:04

Impact: Customers in the UAE, South Africa, and Pakistan regions may have experienced delays, missing messages, or errors on SMS, Voice, WhatsApp, and Email services

*Post-incident update: After further analysis, it was confirmed that impact could have been experienced globally rather than limited to the previously specified regions
Posted May 12, 2026 - 19:21 UTC

Investigating

Our engineering and network teams are actively investigating reports of service degradation affecting our data centers in the UAE, South Africa, and Pakistan.
Upon further investigation, we can confirm that customers in these regions may experience delays, missing messages, timeouts, or errors affecting SMS, Voice, WhatsApp, and Email services, as well as traffic processing across multiple channels.
We will continue monitoring the situation closely and will share additional updates as soon as new information becomes available.
Posted May 12, 2026 - 19:09 UTC
This incident affected: Email (Pakistan), SMS (Pakistan, South Africa), WhatsApp Business (United Arab Emirates), and Voice (South Africa, United Arab Emirates).