Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - Online payments degradation

Incident Report for Infobip

Resolved

Dear Customer,
The issues with the Online Payments through Portal have been resolved. After monitoring and verification, our dedicated team confirms that all services are operating normally.
Posted Mar 14, 2026 - 22:28 UTC

Update

We are continuing to investigate this issue.
Posted Mar 14, 2026 - 22:00 UTC

Update

We are continuing to investigate this issue.
Posted Mar 14, 2026 - 21:26 UTC

Investigating

We are currently experiencing issues with the Online Payments through Portal. Our internal team is actively investigating the extent of this issue, and further details will be provided shortly.
Posted Mar 14, 2026 - 21:25 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States).