Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - Customer Portal issues

Incident Report for Infobip

Resolved

The issue has been successfully resolved, and the service is once again operational.

During the incident, you may have experienced issues with portal access.

Start (UTC): 30 June 2026 07:22
End (UTC): 30 June 2026 07:49
Impact: Customer portal access
Posted Jun 30, 2026 - 08:01 UTC

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 07:48 UTC

Investigating

We are experiencing a degradation of our Customer Portal services. You may experience a blank page or an unexpected error being returned on portal pages.

Our team is investigating the issue, and we will post further updates.
Posted Jun 30, 2026 - 07:47 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States).