Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2024 - 04:00 UTC
Scheduled
We will be undergoing an planned maintenance of database infrastructure on our United States data center. While interruptions are not anticipated, there is a potential for brief disruptions for services hosted at our United States data center during the scheduled maintenance window.
Start (UTC): 12 November 2024 04:00 End (UTC): 12 November 2024 08:00 Purpose: Database upgrade and optimization
Posted Oct 28, 2024 - 12:56 UTC
This scheduled maintenance affected: SMTP (United States), Email (United States), People (United States), Moments (United States), ChatApps (United States), WhatsApp Business (United States), SMS (United States), Number Lookup (United States), SMPP (United States), HTTP API (United States), SIP Trunk (United States), and Voice (United States).