Start (UTC): 18 March 2026 10:25 End (UTC): 18 March 2026 10:48 Impact: Connectivity issues
Posted Mar 18, 2026 - 10:56 UTC
Investigating
We are currently experiencing connectivity issues at our Canada data center. You may experience connectivity issues and service degradation. Our team is inspecting the issue and more details will follow in the next update.
Start (UTC): 18 March 2026 10:33
Posted Mar 18, 2026 - 10:40 UTC
This incident affected: MMS (Canada) and SMS (Canada).