Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Customer Portal Degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved, and the service is once again operational.

During the incident, you may have experienced issues with viewing Analytics dashboard.

Start time (UTC): 20 August 2026 01:56
End time (UTC): 20 August 2026 03:26
Impact: Customer portal data loading issue on Analytics dashboard.
Posted Aug 20, 2026 - 03:52 UTC

Update

We are continuing to investigate this issue.
Posted Aug 20, 2026 - 03:15 UTC

Investigating

This is to inform you that we are experiencing an issue with Customer Portal. You may experience data loading issue or an unexpected error being returned on portal pages. Our team is already working on this case, and more information will follow once it is available.
Posted Aug 20, 2026 - 02:36 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe)).