The issue has been successfully resolved, and the service is once again operational.
During the incident, you may have experienced issues with creating email broadcasts.
Start time (UTC): 20-08-2026 07:20 End time (UTC): 20-08-2026 08:10
Impact: Unable to create an email broadcast
Posted Aug 20, 2026 - 08:23 UTC
Investigating
This is to inform you that we are currently experiencing an issue with the Email Broadcast Service, where users may encounter issues when trying to create a broadcast.
Our team is already working on this case, and more information will follow once it is available.
Posted Aug 20, 2026 - 07:49 UTC
This incident affected: Moments (Global (Europe)).