Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - People Service Degradation

Incident Report for Infobip

Resolved

This incident has been resolved. During the time period below, users may have experienced issues affecting the overall operations of the People Module services.

Start time (UTC): 24-07-2025 01:07
End time (UTC): 24-07-2025 02:41
Impact: Issues in accessing and managing data in the People Module.
Posted Jul 24, 2025 - 03:40 UTC

Investigating

You may experience issues while trying to use and manage data in People module. Our team is working on this, and more information will follow soon.
Posted Jul 24, 2025 - 02:50 UTC
This incident affected: People (Global (Europe)).