Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2025 - 07:01 UTC
Scheduled
We will be performing a planned load test of SMS Mobile Originated traffic over our United States data center. This testing will help ensure continued performance and stability of our service.
Start (UTC): 18 September 2025 07:00 End (UTC): 18 September 2025 10:00 Purpose: SMS MO traffic processing service performance and stability optimization.
Due to redundancy, impact on SMS MO traffic processing during the activity is not expected.
Posted Aug 25, 2025 - 13:15 UTC
This scheduled maintenance affected: SMS (United States).