The issue has been successfully resolved, and the service is once again operating normally.
During the incident, you may have experienced delays in the delivery of seen/read reports for WhatsApp, Viber, TikTok, RCS, and Push channels. Seen status updates may have been delayed or temporarily unavailable. Outbound message delivery was not affected.
Start time (UTC): 24-08-2026 18:23 End time (UTC): 24-08-2026 18:59
Impact: Delayed processing and delivery of seen/read reports for WhatsApp, Viber, TikTok, RCS, and Push channels from the Great Britain Data Center.
Posted Aug 24, 2026 - 19:05 UTC
Investigating
We are currently investigating an issue in our Great Britain Data Center affecting the delivery of seen/read reports for WhatsApp, Viber, TikTok, RCS, and Push channels.
You may experience delays in the delivery of seen/read reports for WhatsApp, Viber, TikTok, RCS, and Push channels. Seen status updates may be delayed or temporarily unavailable, while outbound message delivery continues to function normally.
Our engineers are actively investigating the issue and working to identify the root cause.
Posted Aug 24, 2026 - 18:52 UTC
This incident affected: Mobile Push Notifications (Great Britain), RCS (Great Britain), WhatsApp Business (Great Britain), and ChatApps (Great Britain).