Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global - Customer Portal Service Degradation

Incident Report for Infobip

Resolved

The incident has been resolved.

Start (UTC): 28 April 2026 07:59
End (UTC): 28 April 2026 08:23

Impact: Users may encounter errors when accessing the portal or attempting to log in.

Thank you for your understanding and patience.
Posted Apr 28, 2026 - 08:53 UTC

Monitoring

A fix has been implemented, and we are monitoring the system to ensure stability.
Posted Apr 28, 2026 - 08:36 UTC

Update

We are continuing to investigate this issue.
Posted Apr 28, 2026 - 08:24 UTC

Investigating

We are currently experiencing issues with Customer Portal services. Users may encounter errors when accessing the portal or attempting to log in.
Posted Apr 28, 2026 - 08:19 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe), EU Region-locked, United States).