The scheduled maintenance of our network infrastructure has been cancelled.
We apologize for the inconvenience. You will be informed in a timely manner if the maintenance is rescheduled
Posted Nov 05, 2025 - 07:18 UTC
Scheduled
We will be performing planned maintenance of network infrastructure at our Vietnam data center to upgrade core networking equipment, ensuring stability and optimal performance.
Preventive measures have been implemented to minimize any potential impact, however, brief connectivity interruptions may occur for services hosted at the Vietnam data center. Any disruptions are expected to last no longer than a total of 30 minutes within the scheduled maintenance window.
Start (UTC): 10 November 2025 19:00 End (UTC): 10 November 2025 22:00 Purpose: Network infrastructure upgrade and optimization
Posted Oct 27, 2025 - 13:48 UTC
This scheduled maintenance affected: SMS (Vietnam), Number Lookup (Vietnam), SMPP (Vietnam), and HTTP API (Vietnam).