The issues with our EU Region-locked data center have been resolved, and the services are once again operational. During the specified timeframe, you may have experienced delays and issues with traffic processing on various hosted services and Portal login issues.
Start (UTC): 27 April 2025 22:12 End (UTC): 28 April 2025 00:39
Impact: Issues with all our services hosted on the EU Region-locked data center
Posted Apr 28, 2025 - 01:33 UTC
Identified
The issue has been identified, and we're working further to resolve the situation.
Posted Apr 28, 2025 - 00:41 UTC
Update
We are continuing to investigate this issue.
Posted Apr 28, 2025 - 00:13 UTC
Investigating
We are currently experiencing issues with all our services hosted on the EU Region-locked data center. The scope of the issue is currently being investigated, and more information will follow in the next update.
Posted Apr 27, 2025 - 22:28 UTC
This incident affected: RCS (EU Region-locked), Live Chat (EU Region-locked), Customer Portal Login/Homepage (EU Region-locked), People (EU Region-locked), Moments (EU Region-locked), Analyze (EU Region-locked), Conversations (EU Region-locked), Answers (EU Region-locked), Channels and Numbers (EU Region-locked), Other Portal Apps (EU Region-locked), SMS (EU Region-locked), Number Lookup (EU Region-locked), Email (EU Region-locked), WhatsApp Business (EU Region-locked), ChatApps (EU Region-locked), SMPP (EU Region-locked), HTTP API (EU Region-locked), SMTP (EU Region-locked), Voice (EU Region-locked), and SIP Trunk (EU Region-locked).