Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - WhatsApp service degradation

Incident Report for Infobip

Resolved

This is to inform you that the degradation of our WhatsApp service hosted in our Global (Europe) data centers has been successfully resolved. During the incident timeframe, Infobip customers using the WhatsApp service may have experienced issues and delay in processing of outbound traffic, as well as delayed delivery and “seen” reports.

Start (UTC): 25 February 10:04
End (UTC): 25 February 10:42
Impact: You might have experienced issues and delay in processing of outbound traffic, as well as delayed delivery and “seen” reports.
Posted Feb 25, 2026 - 11:00 UTC

Investigating

We are currently experiencing an issue with the WhatsApp service hosted on our Global (Europe) data centers. You may notice delays and issues affecting inbound and outbound traffic processing.
Our team is investigating, and we will share more details in the next updates.
Posted Feb 25, 2026 - 10:39 UTC
This incident affected: WhatsApp Business (Global (Europe)).