The issue has been successfully resolved and the service is once again fully operational. We had experienced degradation of our Customer Portal in all of our Data Centers.
Start: 21 June 2026 18:55 UTC End: 21 June 2026 19:53 UTC
Impact: You may have experienced issue to log in the Customer Portal.
Posted Jun 21, 2026 - 20:27 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2026 - 20:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2026 - 19:59 UTC
Investigating
We are experiencing a degradation of our Customer portal services. You may experience issues while login in.
Posted Jun 21, 2026 - 19:51 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Pakistan, Qatar, Saudi Arabia, Turkey, United Arab Emirates, United States).