We will be undergoing scheduled maintenance during this time.
Posted Jun 18, 2025 - 11:40 UTC
Scheduled
We will undergo a planned maintenance of our United Arab Emirates data center's database infrastructure that might affect the seamless operation of the People service hosted at this location.
During this activity, brief interruptions are possible when performing actions related to viewing and updating data within the People service (over Customer Portal and/or API), as well as services where People integrates (Moments, Conversations, Answers, Mobile messaging).
Start (UTC): 08 July 2025 16:00 End (UTC): 08 July 2025 18:00 Purpose: Infrastructure upgrade and optimization
Posted Jun 18, 2025 - 11:35 UTC
This scheduled maintenance affects: People (United Arab Emirates).