The degradation has been successfully resolved, and the service is once again operational.
Start (UTC): 16 March 2025 02:00 End (UTC): 16 March 2025 07:30
Impact: Message processing issues. Affected clients experienced delays with their traffic.
Posted Mar 16, 2025 - 08:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2025 - 06:59 UTC
Update
We are continuing to investigate the issue.
Posted Mar 16, 2025 - 06:32 UTC
Investigating
We are currently experiencing issues with the message processing service over our Global (Europe) data center. You might experience issues with delayed processing of messages. The issue is currently being investigated and more information will follow in the next update.
Posted Mar 16, 2025 - 06:00 UTC
This incident affected: SMS (Global (Europe)), Email (Global (Europe)), WhatsApp Business (Global (Europe)), and ChatApps (Global (Europe)).