The incident has been resolved. Start: 08.09.2026 08:25 UTC End: 08.09.2026 12:42 UTC Impact: Users with 2FA (Two-Factor Authentication) enabled could experience login issues.
Posted Sep 08, 2026 - 13:04 UTC
Investigating
We are currently experiencing an issue affecting Customer Portal login. Users with 2FA (Two-Factor Authentication) enabled may get stuck at the final code confirmation step.
Our teams are currently investigating the issue, and further updates will follow
Posted Sep 08, 2026 - 12:43 UTC
This incident affected: Customer Portal Signup/Login (Global (Europe), EU Region-locked, Great Britain, India, Indonesia, Qatar, United Arab Emirates, United States).