Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Global (Europe) - Broadcast service degradation

Incident Report for Infobip

Resolved

This is to inform you that the previously reported service degradation has been successfully resolved. During the incident timeframe, you may have experienced issues with Broadcast campaign processing within the Moments module.

Start (UTC): 21 March 2026, 07:12
End (UTC): 21 March 2026, 08:31
Impact: Broadcast campaigns were failing after launch.
Posted Mar 21, 2026 - 08:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 21, 2026 - 08:34 UTC

Investigating

We're currently experiencing degradation with our Broadcast service within Moments, our designated engineering team is currently investigating and we'll keep you updated.
Posted Mar 21, 2026 - 08:10 UTC
This incident affected: Moments (Global (Europe)).