The issue affecting Moments Services has been successfully resolved and the product is once again fully operational.
Start: 24 June 2026 12:46 UTC End: 24 June 2026 16:37 UTC
Impact: The incident caused a general degradation of the Moments service, resulting in delayed processing of messages and actions across all channels when used via Moments. Traffic outside of Moments was not affected. The issue has been fully resolved, all queued messages have been processed, and the system is now operating normally.
Posted Jun 24, 2026 - 17:04 UTC
Update
We have identified the root cause of this incident, and our engineering team is actively working on a solution.
Some messages processed during the incident window may experience delays and will be reprocessed once services are fully restored.
We will provide further updates once the services have been confirmed to have recovered.
Posted Jun 24, 2026 - 15:41 UTC
Update
Our engineering team is actively investigating the issue and we will share additional updates as soon as new information becomes available.
Posted Jun 24, 2026 - 13:48 UTC
Identified
We are continuing to work on a fix for this issue and our engineering team is actively investigating. We will provide further updates as soon as new information becomes available.
Posted Jun 24, 2026 - 13:30 UTC
Investigating
This is to inform you that we are currently experiencing degradation with multiple services. You may observe delays with usage and processing. Our team is working on this and more updates will follow in the next update.
Posted Jun 24, 2026 - 13:10 UTC
This incident affected: Moments (Global (Europe)), Conversations (Global (Europe)), Email (Global (Europe)), RCS (Global (Europe)), WhatsApp Business (Global (Europe)), SMS (Global (Europe)), and Voice (Global (Europe)).