The issue has been successfully resolved, and the services are once again operational. Start (UTC): 19 February 15:31 End (UTC): 20 February 01:15 Impact: You may have experienced delays in the processing of SMS, email, and WhatsApp traffic.
Posted Feb 20, 2025 - 01:42 UTC
Investigating
We are currently experiencing issues with SMS, email, and WhatsApp service over our Global (Europe) data center. The issue is currently being investigated, and more information will follow in the next update.
Posted Feb 20, 2025 - 01:14 UTC
This incident affected: SMS (Global (Europe)), Email (Global (Europe)), and WhatsApp Business (Global (Europe)).