Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2025 - 10:00 UTC
Scheduled
We will be performing emergency maintenance on our Voice services in our Saudi Arabia data center to enhance the performance and reliability of our platform. During the maintenance window preventive measures have been implemented to minimize any potential impact, however, brief service interruptions are possible for the components listed below.
Start: 08 December 2025, 10:00 UTC End: 08 December 2025, 10:30 UTC
Purpose: Database infrastructure maintenance
Posted Dec 05, 2025 - 09:24 UTC
This scheduled maintenance affected: SIP Trunk (Saudi Arabia) and Voice (Saudi Arabia).