Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - Customer Portal service degradation

Incident Report for Infobip

Resolved

The incident has been resolved.
Start (UTC): 15 September 2026 11:05
End (UTC): 15 September 2026 13:36
Impact: Users could not log in to Customer Portal. Users could not create and send campaigns in Moments service.
Posted Sep 15, 2026 - 13:45 UTC

Investigating

We are currently experiencing issues with Customer Portal on our EU Region-locked and Canada locations.
Users might encounter issues when trying to log in to Customer Portal. Also, users might notice issues when creating campaigns in Moments service.
Our team is working on resolving the issue.
Posted Sep 15, 2026 - 13:18 UTC
This incident affected: Customer Portal Signup/Login (EU Region-locked) and Moments (EU Region-locked).