Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Unavailability of www.infobip.com due to CloudFlare outage

Incident Report for Infobip

Resolved

The issue has been resolved and www.infobip.com is now fully available.
Posted Nov 18, 2025 - 14:23 UTC

Identified

We are currently experiencing unavailability of www.infobip.com due to a global Cloudflare outage affecting multiple services worldwide.

Our engineering teams are actively monitoring the Cloudflare incident and working on mitigation steps to restore access to our website as soon as possible.

All Infobip platform services remain available and are operating normally. This incident is limited to the www.infobip.com website availability.

We will provide updates here as more information becomes available or once the issue is fully resolved.
Posted Nov 18, 2025 - 13:38 UTC