This is to inform you that the previously reported degradation affecting multiple services, including SMS, Email, and WhatsApp, hosted in our United States data center, has been resolved. During the timeframe below, you may have experienced processing difficulties and delays with outbound traffic:
Start (UTC): 31 March 2026 12:08 End (UTC): 31 March 2026 12:19 Impact: SMS, Email, and WhatsApp outbound traffic processing issues and delivery delays.
Posted Mar 31, 2026 - 12:30 UTC
Investigating
We are currently experiencing issues with multiple hosted services, including SMS, Email, and WhatsApp, hosted in our United States data center. You may experience issues with outbound traffic processing and delivery delays. The issue is currently under investigation, and more information will be shared in the next update.
Posted Mar 31, 2026 - 12:19 UTC
This incident affected: Email (United States), WhatsApp Business (United States), and SMS (United States).