Infobip system status

Infobip system status history

Our status page provides real-time updates on our services.

Downtime isn't shown here? Check external connectivity status

Operational

Maintenance

Major Outage

Degraded

Multiple Locations - RCS Template Service Degradation

Incident Report for Infobip

Resolved

This is to inform you that the previously reported issues affecting the RCS template service across multiple data center locations have now been resolved.

Start (UTC): 07 April 2026 06:10
End (UTC): 08 April 2026 10:57

Impact: Clients may encounter difficulties when working with RCS templates. This may include being unable to view certain templates in the UI due to 500 errors, or seeing missing buttons or parameters. In some cases, this may also impact message delivery or tracking, and delays in processing RCS traffic may occur.
Posted Apr 08, 2026 - 13:19 UTC

Monitoring

The fix has been implemented and 500 errors are no longer observed. We will keep monitoring the situation and update if any further issues occur.
Posted Apr 08, 2026 - 12:13 UTC

Identified

We are currently experiencing issues with the RCS template service across multiple data center locations.

Some clients may encounter difficulties when working with RCS templates. This may include being unable to view certain templates in the UI due to 500 errors, or seeing missing buttons or parameters. In some cases, this may also impact message delivery or tracking, and delays in processing RCS traffic may occur.

Our teams are actively investigating the issue and working toward a resolution. Further updates will be shared as more information becomes available.
Posted Apr 08, 2026 - 09:14 UTC
This incident affected: RCS (Global (Europe), India).